Skip to content
Permalink
master
Go to file
 
 
Cannot retrieve contributors at this time
executable file 84 lines (84 sloc) 2.22 KB
{
"name": "webpack4-starter-kit",
"version": "1.0.2",
"description": "Webpack 4 starter kit",
"main": "./src/index.js",
"scripts": {
"dev": "node ./config/dev",
"debug": "node ./config/debug",
"build": "node ./config/prod",
"httpserver": "http-server ./dist -p 8082 --silent"
},
"husky": {
"hooks": {
"pre-commit": "lint-staged"
}
},
"lint-staged": {
"linters": {
"src/**/*.js": [
"eslint --fix",
"git add"
],
"src/**/*.{css,scss}": [
"stylelint --fix",
"git add"
]
}
},
"license": "MIT",
"devDependencies": {
"autoprefixer": "9.1.0",
"babel-core": "6.26.3",
"babel-eslint": "8.2.6",
"babel-loader": "7.1.5",
"babel-plugin-syntax-object-rest-spread": "6.13.0",
"babel-plugin-transform-es2015-classes": "6.24.1",
"babel-plugin-transform-runtime": "6.23.0",
"babel-preset-env": "1.7.0",
"babel-register": "6.26.0",
"chalk": "2.4.1",
"clean-css-loader": "1.0.1",
"clean-webpack-plugin": "0.1.19",
"copy-webpack-plugin": "4.5.2",
"css-loader": "1.0.0",
"eslint": "5.3.0",
"eslint-config-airbnb-base": "13.0.0",
"eslint-loader": "2.1.0",
"eslint-plugin-import": "2.13.0",
"extract-text-webpack-plugin": "4.0.0-beta.0",
"file-loader": "1.1.11",
"fs-extra": "7.0.0",
"html-loader": "0.5.5",
"html-webpack-plugin": "3.2.0",
"http-server": "0.11.1",
"husky": "1.0.0-rc.13",
"imagemin-webpack-plugin": "^2.2.0",
"img-loader": "^3.0.0",
"lint-staged": "7.2.0",
"node-sass": "4.9.2",
"opn": "5.3.0",
"ora": "3.0.0",
"postcss-loader": "2.1.6",
"pug": "2.0.3",
"pug-html-loader": "^1.1.5",
"resolve-url-loader": "^2.3.0",
"sass-loader": "7.1.0",
"smoothscroll-polyfill": "^0.4.3",
"style-loader": "0.21.0",
"stylelint": "9.4.0",
"stylelint-config-standard": "18.2.0",
"stylelint-scss": "3.2.0",
"stylelint-webpack-plugin": "0.10.5",
"webpack": "4.16.4",
"webpack-cli": "3.1.0",
"webpack-dev-server": "3.1.5",
"webpack-merge": "4.1.4"
},
"dependencies": {
"jquery": "^3.3.1",
"magnific-popup": "^1.1.0",
"normalize.css": "8.0.0",
"slick-carousel": "^1.8.1"
}
}
You can’t perform that action at this time.